Start a new topic

Clare Controls Doorbell Camera Issue

 I purchased this doorbell camera and works fine with it's phone app.  I'm trying to get it to work with Bluecherry.   Bluecherry discovered and created the profile using  rtsp, with /h264/ch01/main/av_stream.  I get a live view, but it will not record from the stream.  It shows one second recordings whether is motion or continuous. 

Has anyone seen this before and have a solution?

Checking the log, I'm getting the following below.  Note that I tried iSPY and it can record.  I'm planning on swapping out my Bluecherry drive with my Zoneminder drive to check on it, along with another product when I get the time.

Oct 10 19:39:18 ubuntu bc-server[1155]: E(9/ Error writing frame to recording:  Invalid data found when processing input
Oct 10 19:39:18 ubuntu bc-server[1155]: E(9/ Failure in recording writing


1 Comment

What got my interest in BluecherryDVR is the client that is based on the Qt cross-development tool, which I use at work. Also that it is Linux-based and didn't need a real powerful system. However, there's a few things missing such as motion indications in the 24/7 recordings. 

I was thinking of writing a program that would scan the videos for motion using OpenCV and write a binary file of 1's and 0's (1 == motion), then add a bar graph under the timeline on the Qt client to show motion on the video using the binary file.  So I purchased the 4-cam package.

About 4 months ago, I purchased a doorbell cam (LTS, Clare Controls, LaView, Nelly's, RCA) and BluecherryDVR would not record the video from it. I asked for assistance to find out why BluecherryDVR would not record the video and was told that it would be looked at when time permitted.

In the mean time, I check out other Linux-based surveillance software to see if it I could record from the doorbell cam.  

1) ZoneMinder: it worked fine but adding 4 high-res cams to it would give a CPU a workout and the video recording quality was not the best.

2) XEOMA: it could not auto find the cam, so I had to manually enter it. About 4 out of 10 times, it would find the cam by entering it manually. I contacted support and within 5 days, they looked at the cam.  They stated that I would have to turn off auto scan on the server and manually enter all my cams. But this option is only on the Pro version and would require purchasing it.  They gave me a demo Pro version to try out, but I had a couple server app seg faults.

Finally, I went to the dark side and tried a few Window-based packages.

3) I-Spy: it found the camera, but I didn' t care for the software and recordings, and had a heavy CPU load.

4) Blue Iris: it found the cam, by manually entering the full rtsp.  But the motion recordings had 1 to 3 seconds skips. However there was an option to use RDP/UDP and turning this on resolved the issue.

After waiting 4 months for Bluecherry to investigate, I've decided to say hello to Blue Iris and good-bye to BluecherryDVR.  There is other software (Milestone, etc) that I didn't look at because after using the Blue Iris demo, it has the features that meet my needs.

Login or Signup to post a comment